Active BOINC projects => CLIMATE@HOME Version 2 => Topic started by: Dingo on April 17, 2017, 09:04:17 AM

Title: Project Update
Post by: Dingo on April 17, 2017, 09:04:17 AM
I tried to use Linux Debian 8 Jessie and Virtualbox version 5 but got an error.  I have posted a message on their forum.  That is not to say it will not work for you as I have not been able to run any Virtualbox projects in the last few months. (

EDIT:  They replied and said that there is a new version, but I cannot download anything.

OK I have tasks running on Linux 64 bit

Title: Re: Project Update
Post by: Dingo on May 16, 2017, 08:58:09 AM
I think I have had more aborts than I have success but I have over 10K in credits.   I do not have much luck with VirtualHost applications.

Title: Re: Project Update
Post by: Dataman on May 17, 2017, 05:03:53 AM
I tried to run some but there are no tasks available now.   :pcwhack:

Title: Re: Project Update
Post by: kashi on May 17, 2017, 09:32:12 AM
Yes me too, no tasks.

Judging by the small number of total contributors, it appears that not much work has been released so far.

Title: Re: Project Update
Post by: Dingo on May 17, 2017, 10:08:43 AM
Yes no tasks for a while now.  I have one running on Linux and it is up to 10 hours and only 25 % complete.    Hope it is running OK as there has been a problem of the tasks not finishing or doing nothing.  I have it running on Linux command line Virtualbox so I don't know how to look and see if the task is running.

I also have a app_config.xml to restrict to one task on the servers because they take so long and use a bunch of memory:


EDIT:  After some searching I found out how.  I will post here as I will forget otherwise:


[b]VBoxManage list runningvms[/b]

"boinc_4cc4d98e3b4da8c4" {de950143-4f99-4f30-83e2-b0b564a774b3}

root@dingo2:/usr/bin/projects/climateathome.info_climateathome# [b]VBoxManage showvminfo "boinc_4cc4d98e3b4da8c4"[/b]
Name:            boinc_4cc4d98e3b4da8c4
Groups:          /
Guest OS:        Red Hat (64-bit)
UUID:            de950143-4f99-4f30-83e2-b0b564a774b3
Config file:     /usr/bin/slots/0/boinc_4cc4d98e3b4da8c4/boinc_4cc4d98e3b4da8c4.vbox
Snapshot folder: /usr/bin/slots/0/boinc_4cc4d98e3b4da8c4/Snapshots
Log folder:      /usr/bin/slots/0/boinc_4cc4d98e3b4da8c4/Logs
Hardware UUID:   de950143-4f99-4f30-83e2-b0b564a774b3
Memory size:     1024MB
Page Fusion:     off
VRAM size:       8MB
CPU exec cap:    100%
HPET:            off
Chipset:         piix3
Firmware:        BIOS
Number of CPUs:  1
PAE:             on
Long Mode:       on
Triple Fault Reset: off
APIC:            on
X2APIC:          on
CPUID Portability Level: 0
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): HardDisk
Boot Device (2): DVD
Boot Device (3): Not Assigned
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          on
Time offset:     0ms
RTC:             local time
Hardw. virt.ext: on
Nested Paging:   on
Large Pages:     off
VT-x VPID:       on
VT-x unr. exec.: on
Paravirt. Provider: Default
Effective Paravirt. Provider: KVM
State:           running (since 2017-05-17T00:04:45.150000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: off
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0):            Hard Disk Controller
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Hard Disk Controller (0, 0): /usr/bin/slots/0/boinc_4cc4d98e3b4da8c4/Snapshots/{6f2f7126-7a8d-4b2f-83a3-ba809d6df8dd}.vdi (UUID: 6f2f7126-7a8d-4b2f-83a3-ba809d6df8dd)
NIC 1:           MAC: 080027263DD3, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1:          disabled
UART 2:          disabled
UART 3:          disabled
UART 4:          disabled
LPT 1:           disabled
LPT 2:           disabled
Audio:           disabled
Clipboard Mode:  disabled
Drag and drop Mode: disabled
Session name:    headless
Video mode:      720x400x0 at 0,0 enabled
VRDE:            disabled
USB:             disabled
EHCI:            disabled
XHCI:            disabled

USB Device Filters:


Available remote USB devices:


Currently Attached USB Devices:


Bandwidth groups:

Name: 'boinc_4cc4d98e3b4da8c4_net', Type: Network, Limit: 1024 Gbytes/sec

Shared folders:

Name: 'shared', Host path: '/usr/bin/slots/0/shared' (machine mapping), writable

VRDE Connection:    not active
Clients so far:     0

Video capturing:    not active
Capture screens:    0
Capture file:       /usr/bin/slots/0/boinc_4cc4d98e3b4da8c4/boinc_4cc4d98e3b4da8c4.webm
Capture dimensions: 1024x768
Capture rate:       512 kbps
Capture FPS:        25


Configured memory balloon size:      0 MB
OS type:                             Linux26_64
Additions run level:                 2
Additions version:                   5.1.18 r114002

Guest Facilities:

Facility "VirtualBox Base Driver": active/running (last update: 2017/05/16 13:50:43 UTC)
Facility "VirtualBox System Service": active/running (last update: 2017/05/16 13:50:57 UTC)
Facility "Seamless Mode": not active (last update: 2017/05/16 13:50:43 UTC)
Facility "Graphics Mode": not active (last update: 2017/05/16 13:50:43 UTC)


   Name: boinc_36042 (UUID: ad297992-4169-4d68-b8f8-838c4af45d5e) *


Title: Re: Project Update
Post by: Dingo on May 18, 2017, 10:25:12 AM
@Dataman -  I see your task had an error because the machine does not have virtualization turned on.   I see that it is Windows 10 and if it is Windows 10 Home VM does not work on Windows 10 Home edition as there is no where to turn on Virtualization in the BIOS as Windows 10 Home does not include Hyper-V.   I have the same problem with my windows 10 PC.

2017-05-17 17:01:36 (2140): ERROR: Invalid configuration.  VM type requires acceleration but the current configuration cannot support it.
2017-05-17 17:01:36 (2140):
   NOTE: VirtualBox has reported an improperly configured virtual machine. It was configured to require
    hardware acceleration for virtual machines, but your processor does not support the required feature.
    Please report this issue to the project so that it can be addresssed.

Title: Re: Project Update
Post by: kashi on May 18, 2017, 12:54:37 PM
Yes trying to run BOINC VirtualBox projects without first enabling VT-x in BIOS can sometimes cause problems.

If you at some point tried to run VirtualBox tasks with VT-x disabled in BIOS, BOINC remembers that. So after you have then enabled VT-x in BIOS the only way to make BOINC forget about it being disabled previously is to edit one of its files.

First shutdown BOINC client, either select File -> Shutdown connected client or exit BOINC Manager and tell it to shutdown running science apps. Open Windows' Task Manager and make sure boinc.exe is not running.
Find BOINC's data directory, usually C:\ProgramData\BOINC, and open client_state.xml file in Notepad (don't use other editors) and find the following line:


Change the 1 to 0, save the file and restart BOINC. If the line is not in the file or it's already 0 you have some other problem.

I snagged 1 resend task, it ran for 25 hours and granted 800 credit, so I'm on the board :thumbsup:.