BOINC@AUSTRALIA FORUM

Active BOINC projects => EINSTEIN@HOME => Topic started by: jave808 on May 22, 2020, 11:33:05 AM

Title: GPU task not running/progressing
Post by: jave808 on May 22, 2020, 11:33:05 AM
Hi,
I'm new to einstein@home and I'm having some trouble with a task that refuses to progress in % while the computer is not in use. I have selected the GPU be in use when the computer is not in use after 1 minute. So I go away and let the PC do its thing and when I come back to check on progress - nothing!  The percentage done hasn't increased!  I can get the task to work by selecting use GPU always but then that interferes with my use of the PC (slow mouse and scrolling around).

Anyone come across this before?
Title: Re: GPU task not running/progressing
Post by: chooka03 on May 22, 2020, 12:22:12 PM
Hi Jave,

That's an interesting one. I haven't used the "suspend in use" option before. I actually just tried it.... I checked the box to say "suspend GPU when computer is in use" and selected 1 minute. My Einstein wu's continued to crunch and even started a new set of wu's after 1 minute. Wiggle the mouse and they don't stop.

It could be that the project preference override the BOINC preferences? You have the same ability to suspend work in your Einstein preferences. Also just check both preferences (BOINC & project) that you don't have anything in the "compute only between" in regards to hours of the day to crunch/not crunch. I never use these myself.

I'd try the project preferences and see how that goes.
Title: Re: GPU task not running/progressing
Post by: tazzduke on May 22, 2020, 03:48:27 PM
Hi Jave what Einstein tasks are you running on you GPU?
Title: Re: GPU task not running/progressing
Post by: tazzduke on May 22, 2020, 03:57:13 PM
Also please not do not run the GCW GPU apps on any card that has 3gb or less, as these workunits can use anywhere up to 3gb and therefore will fail.
Title: Re: GPU task not running/progressing
Post by: Sean on May 22, 2020, 05:46:01 PM
I can't help with the issue unfortunately, but it might help to install MSI AFterburner, then you can see if the GPU is being used, it has a graph of GPU usage % which is super helpful.
Title: Re: GPU task not running/progressing
Post by: jave808 on May 22, 2020, 09:52:54 PM
Hi Jave what Einstein tasks are you running on you GPU?

Currently Gamma-ray pulsar binary search.
Title: Re: GPU task not running/progressing
Post by: jave808 on May 22, 2020, 09:53:45 PM
Also please not do not run the GCW GPU apps on any card that has 3gb or less, as these workunits can use anywhere up to 3gb and therefore will fail.

Yes, I think I did have one of those that failed. My GTX1050 only has 2GB. Do I select tasks in the Einstein@home preferences?

EDIT: I have deselected GCW apps from running via preferences.
Title: Re: GPU task not running/progressing
Post by: tazzduke on May 22, 2020, 10:10:23 PM
Yep you figured it out. :-)